Search This Blog

Saturday, August 04, 2007

Re: Linux and Inter-vlan Routing

Mahdi Rahimi wrote:

> I Have 10 switch cisco 2950T that connect via 802.1q protocol togather,
> and don't have any Layer 3 switch or Router. I want to know Linux box can
> act as layer 3 device with below config or can inter-vlan Routing???

> My interface scripts is:
>
> auto eth0
> iface eth0 inet static
> address 192.168.100.91
> netmask 255.255.255.0
> vlan_raw_device eth0

This is not a vlan, but the real interface. Use eth0.1 for interface
name if you want vlan1 on etho, eth0.2 for vlan2 on eth0 and so on.

Tip: avoid using vlan1, as it's a special vlan.

For your 3 network cards, if they are connected to the same switch, I
would not use them as separate interfaces to the switch, but instead
group them into an etherchannel. This is what I am using at home (Debian
to a 2950T):

auto bond0 bond0.2

iface bond0 inet manual
slaves eth0 eth1 eth2 eth3

iface bond0.2 inet static
vlan-raw-device bond0
address 10.2.1.1
network 10.2.1.0
netmask 255.255.255.0
broadcast 10.2.1.255

!Cisco:
interface Port-channel1
switchport mode trunk
switchport nonegotiate
flowcontrol send off
!
interface FastEthernet0/9
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
!
interface FastEthernet0/10
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
!
interface FastEthernet0/11
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
!
interface FastEthernet0/12
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
!

--
Tot ziens,

Bart-Jan


--
To UNSUBSCRIBE, email to debian-firewall-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

No comments: